Cannot Deposit API3 via MetaMask

Hi API3 family,

I recently purchased some API3 on Kucoin and transferred it to my MetaMask hoping to stake my tokens for the current 42% APY. However I am receiving an error when attempting to deposit my API3 tokens into I have enough ETHs in my Metamask wallet to cover the gas fees yet I am still having trouble approving the transfer. Anyone have any idea why this might be?


Hey Nelson!

sorry for the delayed reply on here. Going to take this one.

It would help if you could tell us what type of error you are getting.
There are quite some that you can possibly get starting from contract data not being enabled on hardware wallets, to the current Trezor EIP1559 problem or something completely different.

Thanks in advance!

1 Like

have the exact same problem

1 Like

Hey @ziga!

Same here, could you elaborate what “the same” means?
Screenshots, error messages, etc - anything that could give me a clue what you’re struggling with.

1 Like

Hey. I have screen recorded my side and uploaded as an unlisted video on youtube. Please check it out:

1 Like

Is the transaction showing failed on Etherscan?
Do you use a hardware wallet? If so, which one?
Do you have enough ETH?
Have you tried another browser?

1 Like

I have a ledger nano x connected to my Metamask. I have enough ETHs for the gas. It’s not showing up on Etherscan. I have not tried another browser.

I know that Ledgers sometimes have to allow contract data to be executed.
Is that feature enabled on yours?

I have just allowed contract data. Tried again and still same error message

@Nelson Can you use your Ledger+Metamask to interact with any other dapp? For example, can you trade tokens on Uniswap?

had the same problem with other dapps.
Have you Ledger live installed?
Then go to Metamask —> Settings —> advanced —> allow ledger live…

Try again and confirm on ledger live and on the hardware wallet.

So I have now done what you said. I tried again and then it opened my Ledger Live app and it asked me to open Ethereum bridge. I can “now access on third party web apps through websocket.” The only button i can click is “Disconnect” for the popup. So i click that and nothing happened.

I am still receiving the same failure to approve API3 tokens message.

I have never interacted with any dapps before since I am still new to crypto. I tried going to Uniswap to try a test transaction but because of the high gas fees ($5 payment with $168 gas), I haven’t tried it yet.

If contract data is not enabled the Metamask window will still pop up but the actual execution won’t work.
From the sounds of it, it appears like it might be the contract data thing.

I see. Is there anything else I can do about this?

Did you try another browser, just to see if it works on there?

Hey, UgurMersin

Thanks for working with me these few days. I have updated my Ledger Live app and updated the firmware, tried staking again with the same browser and it worked. It required me to approve blind sign though. Aside from that, I have successfully staked my API3 tokens.

My next question becomes:

What happens next now that I have staked my tokens?

Is there another tab where I can view my staking rewards?

and are there any additional actions I need to take?

1 Like

You can participate in governance or delegate your voting power (this costs gas).

Your staking rewards can be seen at the dashboard that
@enormous built: API3 DAO Tracker - on-chain analytics: members, staking rewards, API3 token circulating supply
Simply check for your address and click on it.

Staking rewards are distributed every Thursday at 0:00 UTC.

1 Like

Thank you so much.