Can't confirm staking tokens with MetaMask


A new issue has now arisen on mobile.

The first few ‘‘deposits’’ and ‘‘staking’’ worked.

But now when I click the “Stake” button on to stake already deposited API3 tokens, Metamask does not respond so it is impossible to ‘‘confirm’’ the transaction.

Metamask is connected and is currently showing an APY of 19.4% (please confirm)

Any help/answer as to why will be much appreciated?


Yes, I see 19.4% as the current APY.

Have you tried restarting the MetaMask app and reconnecting?

On mobile, I deleted the Metamask app, then downloaded the app newly and restarted Metamask.
I reconnected Metamask to

I then tapped ‘‘Stake’’ in order to stake the previously and successfully deposited API3.

It failed.

Metamask stated that it failed to load data onto the blockchain and to try again later.

Unfortunately, this is what happens repeatedly.

I then tapped ''Deposit" to deposit API3 tokens. it failed too for the same reason.

I don’t understand how/why it firstly worked, but after a few transactions, then stopped.

PC option?
Also, is there a workaround for Metamask for a pc too as it fails to work on that too using Chrome extension or Brave?


The transactions work on Firefox browser on mobile.