Stake my API3 tokens from Metamask

I am trying to stake my API3 tokens.

As a first test transaction, I withdrew some API3 to Metamask.

On my desktop, Metamask will not accept API3 to be imported.
Why not and how can this be corrected?

On my phone it did accept it and I can see them there in Metamask.
However, I cannot deposit them into the Staking Pool from my Metamask wallet on my phone because of block by BRAVE (browser).
How do I get around this, please?

Hello @GLL19,

You need to click on “Import token”, then “Custom token” and then paste the contract address of the API3 token in there.

Here is the token address of API3: 0x0b38210ea11411557c13457d4da7dc6ea731b88a

Important: Do not send any tokens to this contract address!

What problems are you encountering when trying to stake your tokens via your mobile phone? Are you using one of the following links?


Hi Marcus,

"You need to click on
“Import token”, then “Custom token” and then paste the contract address of the API3 token in there.

Here is the token address of API3: 0x0b38210ea11411557c13457d4da7dc6ea731b88a"

Thanks. On my desktop, I did this (and have done many times before contacting you).

It locates the API3 token but does not show any balance.

But what happens is, when I click “Import Tokens” the spinning timer keeps spinning trying to do something. It doesn’t stop.

Resulting in nothing happening

On my phone, I have tried both the urls. The same message comes up on BRAVE stating “This page wants to interact with BRAVE Wallet.”

I don’t have nor want a BRAVE wallet (I think). Not having done this before I am worried about creating a BRAVE wallet when all I want is to Stake my API3 via Metamask.

So either way (Desktop or Phone) I am stuck. Can you help me with a solution or a workaround, please?
BTW, I have read another very helpful post on this forum advising to clear history/cache. It worked for that person. I have done this too but it still didn’t work.


I’ve seen this on Brave Mobile. Try connecting to in your phone’s native browser instead of Brave. If I use Safari on my iPhone it connects with MetaMask Mobile. You have to use not https://api3.eth because the native browser won’t resolve ENS domains.

FWIW it does look like Brave Wallet can connect to the DAO Dashboard as MetaMask. Although I haven’t staked tokens that way and I don’t know if anyone has ever tested it, the DAO app appears to think it’s connected to MetaMask. That would be at your own risk of course.

1 Like

Hi Ryan,

Thank you so much. It worked on mobile phone.

In order to help other Forum members who may be as frustrated as me when trying to stake API3, until receiving great advice from you.

Step 1 Use your iphone
Step 2 Download Metamask
Step 3 Via Safari (as you advised), open
Step 4 Connect to Metamask.

From there the process to 1. ‘‘Approve’’ and 2. ‘‘Deposit and Stake’’ worked easily and my API3 tokens are now staked and showing

Lastly, make sure you have some ETH in your Metamask account to pay gas fees.

Thanks again Ryan. That’s great and much appreciated support.

Hi Christian,


1 Like

A post was split to a new topic: Can’t confirm staking tokens with MetaMask

Please do not follow the advice of random people on this forum.
Official API3 team members have the api3 logo on their profile.

I’ll make sure somebody gets back to you, but if you are in touch on Discord, do not follow the links some random person is sending you.

*Edit: the answers of Christian were deleted including his profile.

Ok great, thank you

1 Like