Token balance not showing in API3

Hi, really hoping you can help! I’m testing just 5 API3 before staking all. Was finally able to get Metamask to approve the spending limit so it looks like a successful transaction (in Etherscan it says success and I was charged $28 fees ). Then when I hit Deposit a second time, Deposit and Stake button is available but my balance is 0!

I’m not sure what I’m doing wrong? Can you help?

Hi!

Can you post your etherscan transaction here - alternatively we can take this up in private dm on the forum/discord whichever you prefer if you want to keep your address from public

(if you do check out our discord - find me on the right side under the marketing role Auvi#3895)

Hi, Thank you for your help!

There are 2 etherscan transactions. The first one I realize the possible issue is that I tried to approve the tokens from my Ledger account in Metamask and that wouldn’t go through. So I switched to the main Metamask account and that worked. So that’s the first etherscan transaction - BUT - I hadn’t transferred any API3 to that account, which is likely why the balance was 0.

So then I added API3 to my main account and just tried again. Now, the balance is correctly showing 10 tokens but when I hit Deposit and Stake it still says available balance is 0.

I’ve attached screenshots. The first etherscan is the first transaction and second is the most recent one.

Since I assume your API3 is located on your ledger device and you were having issues on that - have you ensured contract data is enabled on the device?

I also suggest you clear your browser cache and history/restart browser too - also when connecting to the staking DAO page please check the top right address on the webpage is correct for the wallet you intend to stake from

You can also refer to our staking guide series on youtube

Hi Auvi! Thanks for your reply. I have indeed troubleshooted all of that – contract data, blind signing, cleared browser cache, restarted browser, checked the wallet address, and so on. I also tried on Firefox with the same result so not sure what is the issue. I will take a look at the video series and see if I’m missing something…

you’ll have to accept my apologies lol - after checking your screenshots again, it appears you’ve already deposited 10 tokens which is why you can’t put more in
image
as per this, you need only hit stake now as the tokens are already in the dao

1 Like

ahhh!!! that makes sense, was driving me crazy, lol. Didn’t even think to look at the staking balance. I will try that. Thank you so much!!

It worked! I’m now staking 10 tokens. Thanks!

3 Likes